Unit completion / progress stops working.

Bugs Reports and Useful Links

Re: Unit completion / progress stops working.

Postby FlyNorwegian » Fri Mar 06, 2015 8:06 am

I think this worked for me :-) Thanks!
FlyNorwegian
 
Posts: 2
Joined: Mon Mar 02, 2015 8:51 pm

Re: Unit completion / progress stops working.

Postby vprountzos » Fri Mar 06, 2015 10:26 am

Hello,

Can you please check in the files i sent you if the following lines of code exist.

In the file student.php (aroung line 30):

Code: Select all
setcookie("parent_sid", session_id(), time()+3600, "/");


In the file EfrontScripts.js

Code: Select all
function getPHPSessionID() {
    var phpSessionId = document.cookie.match(/parent_sid=[A-Za-z0-9]+\;{0,1}/i);
   
     if(phpSessionId == null)
       return '';
    if(typeof(phpSessionId) == 'undefined')
       return '';
    if(phpSessionId.length <= 0)
       return '';

    phpSessionId = phpSessionId[0];
    var end = phpSessionId.lastIndexOf(';');
    if(end == -1)
       end = phpSessionId.length;

    return phpSessionId.substring(11, end);
}
vprountzos
 
Posts: 589
Joined: Tue Feb 19, 2013 11:06 am

Re: Unit completion / progress stops working.

Postby centralridge » Fri Mar 06, 2015 12:42 pm

They both match (there's some whitespace in one that isn't in the other, but diff says they match otherwise.)

This morning when I logged in as my test student in Chrome it worked for about 3 pages. Then I tried in Firefox and it did not work. Tried in IE and it did not work. Logged back in with Chrome and now it's back to not working at all.
centralridge
 
Posts: 8
Joined: Mon Feb 23, 2015 1:33 pm

Re: Unit completion / progress stops working.

Postby vprountzos » Fri Mar 06, 2015 3:21 pm

Hello,

It is strange that this bug fix does not work for you, and even stranger the behavior you are describing. I shall need a full backup of your eFront directory (make a zip of all your files, you can leave the uploads folders out if it is too big) and a mysqldump of your database.

Send them to me at prountzos@efrontlearning.net

Regards
vprountzos
 
Posts: 589
Joined: Tue Feb 19, 2013 11:06 am

Re: Unit completion / progress stops working.

Postby centralridge » Fri Mar 06, 2015 4:18 pm

Email sent. Thanks!
centralridge
 
Posts: 8
Joined: Mon Feb 23, 2015 1:33 pm

Re: Unit completion / progress stops working.

Postby centralridge » Fri Mar 06, 2015 5:01 pm

I recommitted the changes you sent and tried again. It appears to be working correctly now. Will watch what happens with the actual users today. Thanks for the help!
centralridge
 
Posts: 8
Joined: Mon Feb 23, 2015 1:33 pm

Re: Unit completion / progress stops working.

Postby 2ninerniner2 » Mon Mar 09, 2015 8:46 pm

vprountzos wrote:Hello,

This is a know bug that has been already fixed. Please send me the files:

www/student.php
www/js/EfrontScripts.js

Kind regards

V. Prountzos


Where is this 'fixed' version available? :)
Learn WP Basics - WordPress online tutoring, free video and written tutorials.
User avatar
2ninerniner2
 
Posts: 248
Joined: Wed Jul 20, 2011 9:31 pm
Location: Calgary, AB

Re: Unit completion / progress stops working.

Postby vprountzos » Tue Mar 10, 2015 9:26 am

The fix will be available in the next minor release... for the time being, please modify the corresponding file with the above piece of code...
vprountzos
 
Posts: 589
Joined: Tue Feb 19, 2013 11:06 am

Previous

Return to Bugs

Who is online

Users browsing this forum: No registered users and 2 guests

cron