Toggle editor/html mode

Bugs Reports and Useful Links

Toggle editor/html mode

Postby mksarc » Tue Jul 02, 2013 3:39 am

I have a problem with my "Toggle editor/html mode" and have tried several suggestions from another user with no success. It was recommended that I contact a specific user here, but I have not gotten a reply. I have viewed some of the other posts, but it seems nothing I try is making a difference. I am using the Community++ version 3.6.11 build 15059. I am including a forum thread for info on what I have already done. I would greatly appreciate any assistance. Thank you!

ucp.php?i=pm&mode=view&f=0&p=4175

mksarc

PS: I have noticed in the past week that the audio file I have programmed in certain units do not work either. I thought this might shed some more light on the toggle problem. The audio file is present in the file uploads and the html coding reflects the proper file name.
mksarc
 
Posts: 30
Joined: Sat Nov 05, 2011 4:28 am

Re: Toggle editor/html mode

Postby 2ninerniner2 » Wed Jul 03, 2013 6:03 pm

The link you provided is not valid.

Is this the one you have tried?

viewtopic.php?f=1&t=8029&p=26064&hilit=tinymce#p26064

I have had this happen on occasion but my fix was always removing the .gz file from the appropriate folder.
Learn WP Basics - WordPress online tutoring, free video and written tutorials.
User avatar
2ninerniner2
 
Posts: 248
Joined: Wed Jul 20, 2011 9:31 pm
Location: Calgary, AB

Re: Toggle editor/html mode

Postby mksarc » Wed Jul 03, 2013 11:05 pm

oops...sorry. I'm not sure about the link. Yes, I believe that is correct. I have copied all the private posts I have on this, and pasted them below. Thank you for any help. This is a major problem for me and I am desperate. As I said earlier, I believe this problem is also effecting my audio playback on the unit lessons. Thanks again!


Re: Toggle editor problem

Sent: Wed Jun 19, 2013 6:42 pm
by glearner

Yeah, that all looks about right. There's only two things.

1) Make sure the tmp folder is writable
2) I had to change the following in my htaccess file. Did you try this?

Change php_flag to php_value:
php_flag session.save_path /home/users/web/b608/nf.mooseconomy/public_html/cgi-bin/tmp

to:

php_value session.save_path /home/users/web/b608/nf.mooseconomy/public_html/cgi-bin/tmp


If this doesn't work, than I unfortunately don't have any other suggestions other than sending a private message to makrira. He may be able to log into your account and see what else the problem may be. He offered to help me this way but I was able to fix it before he got around to it.

Good luck! and please let me know how it goes.






Re: Toggle editor problem

Sent: Wed Jun 19, 2013 2:02 pm
by mksarc

Hi,

I really appreciate your help in all this. I have gone through the steps you gave me and the Toggle editor/html still does not work.

I thought I would tell you what I have done and see if maybe you could guide me from there.

1) I went to your other post and followed the steps you took there prior to messing with your .htaccess file. I deleted the "editor" folder and re-uploaded the files from the original files, etc.

2) I checked the Maintenance section of the program and now all items are green.

3) The directive "session.save_path" on the PHP Info tab, Master and Local value are the same. They are both as follows: /home/users/web/b608/nf.mooseconomy/public_html/cgi-bin/tmp

4) the .htaccess file is as follows: (Note - I modified the session.save_path in the .htaccess file to what it is now. According to your posts, I could replace the "/tmp" part with the full path. If this is not correct, please let me know and I will change it back. Also, are you saying that the other commands in the "php*" list here may not need to be added?)
--------------------------------------------------------------------------------

php_flag register_globals off
php_flag magic_quotes_gpc off
php_flag session.save_path /home/users/web/b608/nf.mooseconomy/public_html/cgi-bin/tmp
php_value auto_append_file none

Options -Indexes

<IfModule rewrite_module>
RewriteEngine on
RewriteBase /
RewriteCond %{REQUEST_URI} ^(.*)\/content\/lessons\/.*$
RewriteRule !^((.*.php)|(.*\/))$ %1/view_file.php?server=1
</IfModule>

------------------------------------------------------------------------------

Again, thank you for all your help. The editor function is critical to us. I hope we can get this working.

...mksarc






Re: Toggle editor problem

Sent: Fri Jun 14, 2013 10:17 pm
by glearner

hmm. How about this?

1) Try just copying the session path part into your htaccess. The rest may change other configuration you have. php_value session.save_path /tmp If this is giving you the error than it may be the path is different on your server. That's the /tmp part of that line. You can replace that with the full path to your temp folder.

2) Check the Maintenance section of your installation of eFront.
a) do all items have a green checkbox on the Environmental Check page?
b) find the directive "session.save_path" on the PHP Info tab. Is the Master and Local value the same? What are they? They should be the same. You can change the local via the htaccess file. The master is set by your host.

3) Try all the steps I did prior to messing with my htaccess file. See here: viewtopic.php?f=6&t=8029






Re: Toggle editor problem

Sent: Fri Jun 14, 2013 11:50 am
by mksarc

Thanks again for your help...I copied the .htaccess file to the root directory and when I go to the url/website, it gives me an internal error 500, so I had to remove it to allow access to the website. Any ideas?






Re: Toggle editor problem

Sent: Thu Jun 13, 2013 8:56 pm
by glearner

yes, the eFront folder.

I noticed I had an htaccess file in the eFront folder and also another one in the eFront/www folder so i went ahead and added the lines to both. I haven't tried testing yet to see if both are needed.






Re: Toggle editor problem

Sent: Thu Jun 13, 2013 8:48 pm
by mksarc

OK, Thanks. Since my .htaccess is not in the root already, do I simply place it there after editing it? ...and, is the root the "efront" folder?






Re: Toggle editor problem

Sent: Thu Jun 13, 2013 8:07 pm
by glearner

Hi mksarc,

Sure, here is what I did:

1) download the file .htaccess that is stored in the root directory to my local machine;
2) open the file using notepad or some text editor
3) make sure the following is in the file:

php_flag register_globals off
php_flag magic_quotes_gpc off
php_value session.save_path /tmp
php_value auto_append_file none

4) save it and upload back to the sites root directory

Hope this helps.






Toggle editor problem

Sent: Thu Jun 13, 2013 11:23 am
by mksarc

I'm having the same problem with the toggle editor. Could you explain to me the "Session Path" and how to modify it ccording to your last post? Thanks a million!!!


--------------------------------------------------------------------------------

Top
mksarc
 
Posts: 30
Joined: Sat Nov 05, 2011 4:28 am

Re: Toggle editor/html mode

Postby 2ninerniner2 » Thu Jul 04, 2013 8:28 am

@mksarc -

As mentioned, I have had this on a few installs, but have always managed to cure it this way:

- in both the /www/editor/tiny_mce and /tiny_mce_new folders, deleted any .gz files and then did a few "hard refreshes" (ctrl + F5) while in one of the lesson unit edit screens. The visual editor always eventually appeared.

That said, however, and in light of this post with all the .htaccess suggestions, I took a look around my hosting account where I have 4 eFront installations, all in their own folders off the root, which is a WordPress install. Here is what I found:

- nothing! LOL :) the .htaccess in the root has only the WP items
- in ALL 4 of the eF installs, there are NO .htaccess files in the root folder of the install
- the only place I found them was

-- in /www/content/ and it's contents are the usual:
Code: Select all
Options -Indexes
<IfModule rewrite_module>
 RewriteEngine on
 RewriteBase /
 RewriteCond %{REQUEST_URI} ^(.*)\/content\/lessons\/.*$
 RewriteRule !^((.*.php)|(.*\/))$ %1/view_file.php?server=1
</IfModule>


-- in /libraries/ and it's contents are the usual too:
Code: Select all
order deny,allow
deny from all


HOLD THE PRESSES! ... as I was writing this it just came back to me where I found the culprit in one install a long time ago ... an .htaccess file had somehow gotten into the /www/content/lessons folder! I deleted it and lo and behold, back came the Editor Toggle! :)
Learn WP Basics - WordPress online tutoring, free video and written tutorials.
User avatar
2ninerniner2
 
Posts: 248
Joined: Wed Jul 20, 2011 9:31 pm
Location: Calgary, AB

Re: Toggle editor/html mode

Postby mksarc » Fri Jul 05, 2013 7:12 am

Dear 2ninerniner2,

Is that a twin Piper? Anyway, Thank you for helping me with this.

I tried what you said and there were some other .htaccess files in other folders. I deletd all accept the two as you said. There was a gz file so I deleted it. I then went back to a unit to edit and did the cntrl+F5 many times...no change in the toggle. What am I missing? Thanks!

mksarc
mksarc
 
Posts: 30
Joined: Sat Nov 05, 2011 4:28 am

Re: Toggle editor/html mode

Postby 2ninerniner2 » Fri Jul 05, 2013 9:35 pm

I found this in one older post:

viewtopic.php?f=5&t=7913#p25754

After that, I am all out of suggestions :(

PS> Yep, a Piper Aztec PA-23-250-C
Learn WP Basics - WordPress online tutoring, free video and written tutorials.
User avatar
2ninerniner2
 
Posts: 248
Joined: Wed Jul 20, 2011 9:31 pm
Location: Calgary, AB

Re: Toggle editor/html mode

Postby mksarc » Sat Jul 06, 2013 3:47 pm

Thanks 2ninerniner2 for the link and be safe flying.

Is there someone who can walk me through this step by step to find the problem? Surely as large as the eFront community is, there is someone who knows how to fix this problem and can help me.

Please help!!!

Thanks!!!!

mksarc
mksarc
 
Posts: 30
Joined: Sat Nov 05, 2011 4:28 am

Re: Toggle editor/html mode

Postby vprountzos » Tue Jul 09, 2013 9:53 am

Dear mksarc

Can you please describe me your issue in extended details? Also can you please send me an email to [url]prountzos@efrontlearning.net[/url] with the url of your eFront installation and administrator credentials?

Kind regards

Vasilis Prountzos
vprountzos
 
Posts: 589
Joined: Tue Feb 19, 2013 11:06 am

Re: Toggle editor/html mode

Postby next594 » Wed Dec 21, 2016 10:15 am

Hello! Very interesting topic, thank you raised it
upsers
next594
 
Posts: 3
Joined: Wed Dec 21, 2016 10:12 am


Return to Bugs

Who is online

Users browsing this forum: Google [Bot] and 2 guests