Problem with content files.. Please help.

Bugs Reports and Useful Links

Re: Problem with content files.. Please help.

Postby Tylor Eddy » Tue Nov 22, 2011 11:43 am

G'day Guys,

I am also recieving the forbidden error when trying to update a unit with the Professor account.

Forbidden

You don't have permission to access /academy/www/professor.php on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Has anyone found a solution to this, as it is preventing me from completing a course, as i am trying to edit it to finish it up.

I am using community edition 3.6.10

Regards

Tylor
Tylor Eddy
 
Posts: 2
Joined: Tue Nov 22, 2011 11:39 am

Re: Problem with content files.. Please help.

Postby periklis » Tue Nov 22, 2011 2:49 pm

Hello Tylor,
can you please describe the exact steps you take? I am not sure I understand which page this error results in.
In addition, have a look at admin->maintenance and see if there are any red signs there, indicating a server mis-configuration
Periklis Venakis
eFront- eLearning and Skill Development Solution for Companies and Educational Institutes
Consider our wide range of added-value services to get things running smoothly on your eLearning environment
periklis
 
Posts: 4371
Joined: Thu Oct 04, 2007 10:54 am

Re: Problem with content files.. Please help.

Postby Tylor Eddy » Tue Nov 22, 2011 8:06 pm

G'day,

It occurs when i attempt to submit content for a lesson that i have tried to update, this link may help show you the exact location: http://qantasvirtual.com/academy/www/pr ... ent&edit=2.

It occurs after i click save to update the content in the lesson.

Within the maintenance page i mostly have ticks,for the apache version i have a caution symbol as i do not have apache 2.0, i merly have apache.

Also here is my error log

[06-Nov-2011 14:43:52] PHP Warning: require_once(../libraries/configuration.php) [<a href='function.require-once'>function.require-once</a>]: failed to open stream: No such file or directory in /home/qantasvi/public_html/academy/www/periodic_updater.php on line 23
[06-Nov-2011 14:43:52] PHP Fatal error: require_once() [<a href='function.require'>function.require</a>]: Failed opening required '../libraries/configuration.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/qantasvi/public_html/academy/www/periodic_updater.php on line 23


Tylor
Tylor Eddy
 
Posts: 2
Joined: Tue Nov 22, 2011 11:39 am

Re: Problem with content files.. Please help.

Postby periklis » Wed Nov 23, 2011 12:06 pm

Do you get the same message on any unit, or this specific? Have you noticed similar behavior when submitting other forms as well? (for example, users, tests, questions, etc)
Periklis Venakis
eFront- eLearning and Skill Development Solution for Companies and Educational Institutes
Consider our wide range of added-value services to get things running smoothly on your eLearning environment
periklis
 
Posts: 4371
Joined: Thu Oct 04, 2007 10:54 am

Re: Problem with content files.. Please help.

Postby griffe » Tue Mar 26, 2013 5:44 pm

I'm having the same issue.. Latest release of efront and a clean install...

Uploaded a scorm unit, when to update unit, when I click save I get 'Forbidden' (this is because I have directory listing disabled) but it looks like a 404 when saving...
griffe
 
Posts: 27
Joined: Fri Oct 05, 2012 6:34 pm

Re: Problem with content files.. Please help.

Postby periklis » Mon Apr 08, 2013 11:30 pm

does the save go through after all?
Periklis Venakis
eFront- eLearning and Skill Development Solution for Companies and Educational Institutes
Consider our wide range of added-value services to get things running smoothly on your eLearning environment
periklis
 
Posts: 4371
Joined: Thu Oct 04, 2007 10:54 am

Re: Problem with content files.. Please help.

Postby NextSchool » Tue Aug 16, 2016 2:34 pm

Hello,

firstly i want to apologize for my bad english. I have a very big problem. I use efront version 3.6.15 Community edition, and the last two months when i try to update or change any lesson(swf,mp3 file), it displays me this error: 403 forbidden You don't have permission to access /www/professor.php on this server. Apache Server at nextschool.edu.gr Port 80

Have you any idea how to solve this error???

Regards,
Thanos Tsoutsos
NextSchool
 
Posts: 1
Joined: Tue Aug 16, 2016 2:18 pm

Previous

Return to Bugs

Who is online

Users browsing this forum: No registered users and 1 guest

cron