error uploading scorm package

Bugs Reports and Useful Links

error uploading scorm package

Postby gedeho » Mon Mar 01, 2010 10:29 am

Hi,

I'm currently workin on Efront Community ++ Edition 3.6 - build 6152. All files have been uploaded again this morning, and i restarted an installation process.
Server is managed by Apache 2 with php 5.3.

When i try to upload SCORM 1.2 content in "Import SCORM Content" panel, Efront returns an error : "You cannot upload files with this extension (104)"
The "More Info" link diplays this lines :

#0 /my-host-name/libraries/filesystem.class.php(2902): FileSystemTree::checkFile('')
#1 /my-host-name/libraries/includes/scorm.php(121): FileSystemTree->uploadFile('scorm_file', '/home/elearning...', 1)
#2 /my-host-name/www/professor.php(455): require_once('/home/elearning...')
#3 {main}


During the process, zip files seems correctly uploaded, but doesn't uncompress automaticaly (i have to do it myself by clicking the "uncompress" icon in "Files" panel).

For these tests, the zip package contents only SCORM files (xsd files, imsmanifest.xml file, and an html file). I also tried uplaoding a lone zipped imsmanifest.xml file.
All icons are green on "environmental check" panel and i checked allowed files and disallowed files fields are left blank in "system settings" panel.
I also tried to disable all modules to avoid conflict between some of them...

Result is always the same.

Anyone here have an idea to solve this problem ?
gedeho
 
Posts: 1
Joined: Mon Mar 01, 2010 10:26 am

Re: error uploading scorm package

Postby skippybosco » Mon Mar 01, 2010 11:37 pm

@gedeho: Log on as admin and go to the Maintenance page. Are there any warnings or errors regarding zip support?

Again logged on as admin, go to System Settings. Scroll all the way to the bottom, what is the "Zip Handling Method" set to? (PHP or System).. change the value and test the import again, does it make any difference?
User avatar
skippybosco
 
Posts: 2148
Joined: Fri Aug 22, 2008 7:58 am

Re: error uploading scorm package

Postby periklis » Tue Mar 02, 2010 6:21 am

Have you setup black or white lists for files in the system configuration area? If so, make sure that the zip extension is not cutoff from the server
Periklis Venakis
eFront- eLearning and Skill Development Solution for Companies and Educational Institutes
Consider our wide range of added-value services to get things running smoothly on your eLearning environment
periklis
 
Posts: 4327
Joined: Thu Oct 04, 2007 10:54 am


Return to Bugs

Who is online

Users browsing this forum: No registered users and 1 guest