Login error when already logged in

Suggestions, General Discussion and Feature Requests about eFront

Login error when already logged in

Postby glibdud » Fri Nov 04, 2016 1:29 pm

Hi folks. I've recently (over the last month or two) had a handful of cases of users getting login errors when using the correct username and password. It seemed to be intermittent... it would work one day, not the next, then it would start working again. Yesterday I finally figured out that the issue is that eFront already thinks the user is logged in (I guess from a past session in the same browser). I can reproduce the issue easily... log in to eFront, open a new browser tab, go back to the front page and try to log in again. The only hint that you're already logged in is the little toolbar in the upper right, which most users are understandably not looking for on the login page.

It's a bit odd that we've just started getting reports of this recently. We haven't updated eFront recently (running version 3.6.15). My best guess is that maybe it's related to LDAP. We integrated eFront with our AD server earlier this year, and we're now seeing an increase in activity as people are doing their annual refresher training.

Anyone seen this before? Is there any way to make eFront move right into the user's home page if they try to go to the front page while already logged in, or at least give a more appropriate error message than "Your username or password is incorrect"?
glibdud
 
Posts: 72
Joined: Mon Jan 19, 2009 3:53 pm

Return to eFront

Who is online

Users browsing this forum: No registered users and 4 guests

cron